This incident is now fully resolved and the services are functioning for all customers as expected.
We will continue to monitor the services closely and work on Root Cause Analysis to identify the corrective actions needed to avoid a recurrence.
DXC apologises for the inconvenience and the impact caused to our customers operations.
Posted Sep 18, 2025 - 11:45 BST
Update
Our email delivery issue is now resolved and we continue to work with a small number of individual customers to resolve any pending queries.
We will continue to monitor the services closely. If you do have any remaining unresolved email delivery issues please contact the Velonetic IT Service Centre
DXC apologises for the inconvenience and the impact caused to our customers operations.
Posted Sep 05, 2025 - 15:13 BST
Monitoring
We have applied the fix successfully and are now expecting the email delivery issues at the customer end to be fully resolved. We will confirm early tomorrow and work on any remaining concerns with customers who have reported quarantined email.
We will continue to monitor the services closely and work on the corrective actions needed to avoid a recurrence.
DXC apologises for the inconvenience and the impact caused to our customers operations.
Posted Sep 03, 2025 - 20:45 BST
Update
Our DXC technical team are still working with our vendor to implement the required fix on the DXC Email service.
Once the fix has been deployed Velonetic will be working to resend affected emails where possible.
The next status update will be issued at 21:00
DXC apologises for the inconvenience and the impact being caused to customers operations.
Posted Sep 03, 2025 - 19:01 BST
Investigating
We are experiencing an issue with email delivery, due to a recent security enhancement our outgoing emails sent directly from our applications e.g. Tracker query emails and reporting service emails may be held in quarantine at the customer email gateway depending on the customers email security configuration. Email sent directly from Velonetic employees is unaffected.
Our DXC technical team are working with our vendor to implement the required fix on the DXC Email service.
Once the fix has been deployed Velonetic will be working to resend affected emails where possible.
The next status update will be issued at 19:00
DXC apologises for the inconvenience and the impact being caused to customers operations.
Posted Sep 03, 2025 - 17:07 BST
This incident affected: Policy & Premiums (Premium Tracker) and Data Services (Other DS Reports).