London Market - System Maintenance - Multiple Systems

Scheduled for Jan 22, 20:00 - 22:00 GMT

Update

We will be undergoing scheduled maintenance during this time.
Posted Jan 09, 2026 - 10:59 GMT

Scheduled

DXC would like to inform our customers that we will be performing important system maintenance on 22 January, therefore some of our systems will be unavailable from Thursday 22 January 20:00 - 22:00.

Please see the selected components for the applications / services affected.
Posted Jan 09, 2026 - 10:56 GMT
This scheduled maintenance affects: Repository (IMR, DRI Upload, DRI Download, DRI Search, DRI Notify, Outbound DRI), Claims (DMS, CAS (ECF2), DFV (ECF2)), Xchanging Internal Systems (APIX), and Policy & Premiums (eAccounts/PbS).