Application Issue - Multiple Applications Unavailable

Incident Report for Velonetic Systems

Monitoring

This incident is now fully resolved and the services are functioning as expected.

We will continue to monitor the services closely and work on Root Cause Analysis to identify the corrective actions needed to avoid a recurrence.

Velonetic apologises for the inconvenience and the impact caused to our customers operations.
Posted Sep 24, 2026 - 07:32 BST

Investigating

Velonetic identified an issue with the mainframe platform, impacting multiple applications, including CLASS, ECF2, CASA, Writeback, CWT and DMS.

The relevant teams are actively investigating the issue and working to restore services as quickly as possible.

Our next update will be issued no later than 07:30 hrs.

Velonetic apologises for the inconvenience and the impact being caused to our customers operations.
Posted Sep 24, 2026 - 06:14 BST
This incident affects: Claims (CLASS (CASA), DMS, CAS (ECF2), CAA (ECF2), CWT, Writeback - Claim Notify, Writeback - Claim Retrieve, Writeback - Claim Respond), Batch Messaging (LIMCLM), Velonetic Internal Systems (XCS CLASS), Policy & Premiums (PoSH (CASA)), and Data Services (Other DS Reports).